Opencore Installation Problems | Mac Rumors Forums

Hi, I tried to install OpenCore Legacy Patcher 4.4 on my MacPro 5.1:
The goal was to upgrade to O/S Monterey and enable GPU boot selection on an un-flashed, more modern AMD Radeon 7100WX 8GB card.
2 Intel Xeon 6-core 3.46 GHz processors and 64 GB of RAM
Boot ROM Vsn Firmware Update: 144.0.0.0.0
Metal Supported EFI Driver VSN: 01.00.624
Flashed AMD Radeon R9 280X 3GB installed so I can reboot to whatever system I want

After disabling SIP and rebooting in safe mode, using a clean system (no Apple apps) Samsung 250GB ssd, 2 partitioned, Sierra 10.12 (Mac OS Extended Journaled) / Mojave 10.14.6 (APFS) , installed OpenCore Legacy Patcher 4.4 on Mojave Partition

OpenCore Legacy Patcher 4.4 installation screen shows: Model: MacPro 5.1, however, “Post Install Root Patch” is strangely grayed out, while on various videos it shows as white text on a black box, like all the other options. Still, I figured my MacPro 5.1 didn’t need these patches because it’s compatible with Metal and upgraded to firmware 144.0.0.0.0.

Attempted to create Sandisk USB 32Mb installer with O/S Monterey 17.3.3 in Application folder of Mojave partition, after installing Monterey this error box appeared:

OpenCore install disk error May'22.png

Tried the process again, same error box. Tried with HP USB 32Mb, even downgrading to OpenCore Legacy Patcher 4.3, again same results.

Tried the process again with another Mac: MacBookPro 9.2 running Mojave 10.4.16
2.5 Ghz Intel Core i5 processor and 8 GB of RAM
Metal Supported Feature Set mac OS GPUFamily1 v4
Intel 4000 1536MB graphics card

SIP disabled, reboot in safe mode, using clean system (no Apple apps) Crucial 500 GB ssd, 2 partitioned, Mojave 10.14.6 (APFS)/ Catalina 10.15.4 (APFS), installed OpenCore Legacy Patcher 4.4 on the Mojave partition with O/S Monterey 17.3.3 in the Application folder of the Mojave partition. But again, “Post Install Root Patch” is greyed out:

OpenCore Post Install Root Patch Gray MacBook Pro 9.2 May'22.png

Anyway, I installed the OpenCore application on my Mojave ssd partition, then I also inserted the freshly erased HP USB 32MB installer in case something went wrong, this time I’m informed that everything is fine, so I reboot, the boot selector screen shows the Mojave/Catalina ssd, OpenCore EFI and USB install drive. However, when I select EFI boot, a black Disk Access Forbidden screen pops up (white circle crossed out) and the MacBook Pro shuts down.

Forbidden: forbidden disk access screen.png

Several reboots later reveal that all drives have the black Disk Access Forbidden screen and the MacBook Pro shuts down.
Real problems installing OpenCore on 2 different Mac models, am I missing something?

Please help,

John.aspides@gmail.com


Source link

Steven L. Nielsen